Augustus installation error in Mac OSX 10.10.4

Discussions about compiler errors and installation problems

Moderator: bioinf

Post Reply
User avatar
katharina
Site Admin
Posts: 530
Joined: Wed Nov 18, 2015 6:14 pm
Location: Greifswald
Contact:

Augustus installation error in Mac OSX 10.10.4

Post by katharina »

Originally posted by Evoe on 19.07.2015 - 17:12

I have a problem in installing augustus-3.1 on Mac OSX10.10.4.
When I execute the Makefile, I got this kind of error message:

Code: Select all

g++ -c -Wall -Wno-sign-compare -ansi -pedantic -O3 -DZIPINPUT -o genbank.o genbank.cc -I../include 
In file included from genbank.cc:15: 
In file included from ../include/genbank.hh:19: 
In file included from ../include/gene.hh:16: 
../include/hints.hh:147:7: warning: equality comparison result unused [-Wunused-comparison]
        name == "";
        ~~~~~^evoe? July 19, 2015, at 05:12 PM
../include/hints.hh:147:7: note: use '=' to turn this equality comparison into an assignment
        name == "";
             ^~
             =
In file included from genbank.cc:15: 
In file included from ../include/genbank.hh:19: 
../include/gene.hh:369:10: warning: 'Gene::almostIdenticalTo' hides overloaded virtual function [-Woverloaded-virtual]
    bool almostIdenticalTo(Gene *other);
         ^
../include/gene.hh:295:18: note: hidden overloaded virtual function 'Transcript::almostIdenticalTo' declared here: type mismatch at 1st parameter
      ('Transcript *' vs 'Gene *')
    virtual bool almostIdenticalTo(Transcript *other);
                 ^
../include/gene.hh:386:10: warning: 'Gene::printEvidence' hides overloaded virtual function [-Woverloaded-virtual]
    void printEvidence();
         ^
../include/gene.hh:300:18: note: hidden overloaded virtual function 'Transcript::printEvidence' declared here: different qualifiers (const vs none)
    virtual void printEvidence() const {}; // implemented only for coding genes
                 ^
In file included from genbank.cc:15: 
../include/genbank.hh:26:10: fatal error: 'boost/iostreams/filtering_stream.hpp' file not found
include <boost/iostreams/filtering_stream.hpp>
         ^
3 warnings and 1 error generated. 
make: *** [genbank.o] Error 1
How can I solve this problem?
User avatar
katharina
Site Admin
Posts: 530
Joined: Wed Nov 18, 2015 6:14 pm
Location: Greifswald
Contact:

Re: Augustus installation error in Mac OSX 10.10.4

Post by katharina »

Originally posted by Lizzy in the old forum on 20.07.2015 - 14:13

If you use the DZIPINPUT option you need to install the boost library fist. If you do not use zipped input files I would recommend to turn that option off by setting "ZIPINPUT = false" in the file common.mk and type "make clean all" to try again.

I hope that helps. Let us know if it still doesn't work
User avatar
katharina
Site Admin
Posts: 530
Joined: Wed Nov 18, 2015 6:14 pm
Location: Greifswald
Contact:

Re: Augustus installation error in Mac OSX 10.10.4

Post by katharina »

Originally posted by evoe in the old forum on 20.07.2015 - 15:41

Hi Lizzy,

Thank you for your kind advice.

However, I already installed boost and I followed the step you suggested (turn that option off by setting "ZIPINPUT = false" in the file common.mk),
I got the same error message.
User avatar
katharina
Site Admin
Posts: 530
Joined: Wed Nov 18, 2015 6:14 pm
Location: Greifswald
Contact:

Re: Augustus installation error in Mac OSX 10.10.4

Post by katharina »

Originally posted by Lizzy in the old forum on 04.08.2015 - 15:30

oh, I just tried and realized it doesn't work by setting ZIPINPUT = false. It still compiles with ZIPINPUT option turned on. That's probably a bug. Please try commenting out that line in common.mk, so that the line is ignored: "# ZIPINPUT = false". That should work, hopefully. Sorry for the inconvenience.
User avatar
katharina
Site Admin
Posts: 530
Joined: Wed Nov 18, 2015 6:14 pm
Location: Greifswald
Contact:

Re: Augustus installation error in Mac OSX 10.10.4

Post by katharina »

Originally posted by evoe in the old forum on 12.08.2015 - 06:58

I tried commenting out "# ZIPINPUT = false" line, but I got the same error.
I gave up running Augutus3.1 on Mac OSX 10.10.4, now I utilize it on Biolinux8.
Thank you.
Post Reply